// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^aaa\s+accounting system default(?:\s+action-type)?\s+start-stop\s+group\s+tacacs\+").unwrap();
let string = "aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}