package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[.*\])`)
var str = `a[33] [44] [3435]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}