re = /\?{2,}|\?/m
str = 'Хм...............привет...........как дела?????????????'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end