re = /(?:\s|^)([^\s\.]+(?=\s*\{))/m
str = '.test{}
test{}
.bar {}
foo {}
. --^-foo { bla }
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end