re = /(([\w]*)(-?)([\w]{0,2})(.apps)(-?)([\w]{0,2})(.[\W\w]*))/
str = 'somestupidurls-qp.apps-np.blahblah.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end