re = /(?i)(?<=\{|\G|\{%@|\G%@)([a-z0-9]+)(?:%?\s*(?:,\s*|\}))/m
str = 'MyTokenName{%@example1%, %@example2%}
MyTokenName{example1, example2}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end