re = /(?!{ignoreme})[\s\[\]{}()<>\\'"|^`]/i
str = 'aaa{ignoreme}asdebla bla f{}asdfdsaignoreme}asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end