re = /{[^}]+}(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)/
str = '{-1} This is the string and it "contains {0}" a few {1} sets of curly brackets "contains {2}" {3}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end