re = /(?:youtube\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)([^"&?\/ ]{11})/i
str = 'https://www.youtube.com/watch?v=hn1rArzPE1s'
# Print the match result
str.match(re) do |match|
puts match.to_s
end