import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(<))([^\\/].+?)(>)";
final String string = "<script type=\"text/javascript\">\n\n"
+ " inner_text_1\n"
+ " <c:set var=\"\" value=\"\">inner_text_2</c:set>\n\n"
+ "</script>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}