use strict;
my $str = 'Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Option1:* Hi Ted Warren *Option2 Juan<\\person>
';
my $regex = qr/(?!.*Option2.*)Option1:\*.*?(?P<Capture>(Bob|David|Ted|Alice))|\*Option2 (?P<Capture2>Juan)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}