re = /(?!.*Option2.*)Option1:\*.*?(?P<Capture>(Bob|David|Ted|Alice))/
str = 'Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Bla bla bla Option1:* Hi Ted Warren *Option2 Juan<\\person>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end