re = /(?=(?:.*a){3}.*)(?=(?:.*b){3}.*)(?=(?:.*c){3}.*|[^c]*).*/m
str = 'aa aaabbb aa
aaabbbc ababab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end