$re = '/[^ ,>]* [^ ,<\/]*/m';
$str = '<p>Word word and word2? But word word to.</p>
<p> word this is an <a href="#">example</a></p>
<p>this is another example</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);