#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*?[+-])(?=.*?[0-9]).[0-9]+$"
Local $sString = "+343" & @CRLF & _
"asdf." & @CRLF & _
"23fsdf" & @CRLF & _
"as334" & @CRLF & _
"-122" & @CRLF & _
".4487" & @CRLF & _
"|5445" & @CRLF & _
"-" & @CRLF & _
"+" & @CRLF & _
"+23.23" & @CRLF & _
"-23,23" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")