$re = '/^([1-9]\d\d\d*|[3-9]\d|2[5-9])000$/m';
$str = '25000
26000
26999
34000
123000
321000
2500000
000
20000
abc000
0000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);