$re = '/^(\+\d{1,3}[- ]?)?\d{10}$/';
$str = '345678765
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);