#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[\[).*(?=\]\])"
Local $sString = "__NOTOC__" & @CRLF & _
"" & @CRLF & _
"{{SubTOC|Titel=Liste von Autoren|Index=Liste von Autoren}}" & @CRLF & _
"" & @CRLF & _
"== Aa ==" & @CRLF & _
": [[Bertus Aafjes]] (1914–1993), NL" & @CRLF & _
": [[Jeppe Aakjær]] (1866–1930), DK" & @CRLF & _
": [[Johannes Aal]] (um 1500–1551), CH" & @CRLF & _
": [[Hans Aanrud]] (1863–1953), NO" & @CRLF & _
": [[Emil Aarestrup]] (1800–1856), DK" & @CRLF & _
": [[Soazig Aaron]] (* 1949), FR" & @CRLF & _
": [[Ivar Aasen]] (1813–1896), NO" & @CRLF & _
"" & @CRLF & _
"== Ab ==" & @CRLF & _
": [[Petrus Abaelardus]] (1079–1142), FR" & @CRLF & _
": [[Sait Faik Abasıyanık]] (1906–1954), TR" & @CRLF & _
": [[Lynn Abbey]] (* 1948), US" & @CRLF & _
": [[Jacob Abbott]] (1803–1879), US" & @CRLF & _
": [[John Stevens Cabot Abbott]] (1805–1877), US" & @CRLF & _
": [[Abdullah bin Abdul Kadir]] (1795–1852), MAL" & @CRLF & _
": [[Abe Kōbō]] (1924–1993), JP" & @CRLF & _
": [[Rebecca Abe]] (* 1967), D "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")