// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\|\|\s+(?<field1>[^ ]*)\s+\|\s+[^ ]*\s+\|\s+(?<field2>[^ ]*)").unwrap();
let string = "|| va1eb01 | PROD | Provider86 | 2017-06-14 18:03:19,726 | ERROR | http--10.100.108.44-8080-116 | com.amerigroup.geocode.v3geocoder.GoogleGeoCodeV3.getGeocodeResponse(GoogleGeoCodeV3.java:252) | IOException, geocodeUrl=**http://maps.google.com/maps/api/geocode/xml?sensor=false&client=gme-amerigroupcorp&address=5741+S+FT+APACHE+RD+STE+100%2CLAS+VEGAS%2CNV+89148-5622%2CUSA&signature=o3Jsz1z-qNPB35WGdVY-bPFrMc8=: java.io.IOException: Server returned HTTP response code: 500 for URL: http://maps.google.com/maps/api/geocode/xml?sensor=false&client=gme-amerigroupcorp&address=5741+S+FT+APACHE+RD+STE+100%2CLAS+VEGAS%2CNV+89148-5622%2CUSA&signature=o3Jsz1z-qNPB35WGdVY-bPFrMc8=**
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1626)
at com.amerigroup.geocode.v3geocoder.GoogleGeoCodeV3.getGeocodeResponse(GoogleGeoCodeV3.java:229)
... 46 lines omitted ...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}