import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Current File:\\s*(\\S+\\.txt).*Old File:\\s*(\\S+\\.txt)[\\s\\S]*?(?=-{4,})";
final String string = "Current File: week-28\\gcweb.txt (=>) ########## Old File: week-27\\gcweb.txt (<=)\n\n\n\n"
+ "2019-07-21 13:20:42 ip-172-17-3-71=>\n"
+ "2019-07-17 13:27:12 ip-172-17-3-71<=\n"
+ "--------------------------------------------------\n"
+ "--------------------------------------------------\n"
+ "Current File: week-28\\gcckup.txt (=>) ########## Old File: week-27\\gcckup.txt (<=)\n\n\n\n"
+ "2019-07-21 13:20:46 ip-172-17-2-101=>\n"
+ "2019-07-17 13:27:14 ip-172-17-2-101<=\n"
+ "--------------------------------------------------\n"
+ "--------------------------------------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}