const regex = /@@colored:(.*?) @color:(.*?)@@/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@@colored:(.*?) @color:(.*?)@@', 'gs')
const str = `some text @@colored:South Africa, officially the Republic of South Africa, is the southernmost country in Africa. It is bounded on the south by 2,798 kilometers of coastline of southern Africa stretching along the South Atlantic and Indian Oceans on the north by the neighbouring countries of Namibia, Botswana and Zimbabwe, and on the east by Mozambique and Swaziland, and surrounding the kingdom of Lesotho.[12] South Africa is the 25th-largest country in the world by land area, and with close to 53 million people, is the world's 24th-most populous nation. @color:red@@ another text
`;
const subst = `<p style='color:$2;'>$1</p>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);