import Foundation
let pattern = #"@@colored:([^ ]*(?: (?!@color:)[^ ]*)*) @color:([^@]*(?:@(?!@)[^@]*)*)@@"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
some text @@colored:South Africa, officially the Republic of South Africa, is the southernmost country in Africa. It is bounded on the south by 2,798 kilometers of coastline of southern Africa stretching along the South Atlantic and Indian Oceans on the north by the neighbouring countries of Namibia, Botswana and Zimbabwe, and on the east by Mozambique and Swaziland, and surrounding the kingdom of Lesotho.[12] South Africa is the 25th-largest country in the world by land area, and with close to 53 million people, is the world's 24th-most populous nation. @color:red@@ another text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p style='color:$2;'>$1</p>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}