$re = '/^(?!.*([!$%^&*()_+|~=`{}\[\]:";\'<>?,.\/-]).*\1)[!$%^&*()_+|~=`{}\[\]:";\'<>?,.\/A-Za-z0-9-]+$/m';
$str = 'abc12*$%
abcd12324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);