re = /\b[submarine]+\b/
str = 'For example, if I have a string submarine I want to be able to detect marines as a match.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end