const regex = /((^090)([23589]))|((^070)([1-9]))|((^080)([2-9]))|((^081)([0-9]))(\d{7})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^090)([23589]))|((^070)([1-9]))|((^080)([2-9]))|((^081)([0-9]))(\\d{7})', '')
const str = `08121434763`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}