#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]?\d|1\d\d|2[0-4]\d|25[0-5])$"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"12" & @CRLF & _
"13" & @CRLF & _
"14" & @CRLF & _
"15" & @CRLF & _
"16" & @CRLF & _
"17" & @CRLF & _
"18" & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"22" & @CRLF & _
"23" & @CRLF & _
"24" & @CRLF & _
"25" & @CRLF & _
"26" & @CRLF & _
"27" & @CRLF & _
"28" & @CRLF & _
"29" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"32" & @CRLF & _
"33" & @CRLF & _
"34" & @CRLF & _
"35" & @CRLF & _
"36" & @CRLF & _
"37" & @CRLF & _
"38" & @CRLF & _
"39" & @CRLF & _
"40" & @CRLF & _
"41" & @CRLF & _
"42" & @CRLF & _
"43" & @CRLF & _
"44" & @CRLF & _
"45" & @CRLF & _
"46" & @CRLF & _
"47" & @CRLF & _
"48" & @CRLF & _
"49" & @CRLF & _
"50" & @CRLF & _
"51" & @CRLF & _
"52" & @CRLF & _
"53" & @CRLF & _
"54" & @CRLF & _
"55" & @CRLF & _
"56" & @CRLF & _
"57" & @CRLF & _
"58" & @CRLF & _
"59" & @CRLF & _
"60" & @CRLF & _
"61" & @CRLF & _
"62" & @CRLF & _
"63" & @CRLF & _
"64" & @CRLF & _
"65" & @CRLF & _
"66" & @CRLF & _
"67" & @CRLF & _
"68" & @CRLF & _
"69" & @CRLF & _
"70" & @CRLF & _
"71" & @CRLF & _
"72" & @CRLF & _
"73" & @CRLF & _
"74" & @CRLF & _
"75" & @CRLF & _
"76" & @CRLF & _
"77" & @CRLF & _
"78" & @CRLF & _
"79" & @CRLF & _
"80" & @CRLF & _
"81" & @CRLF & _
"82" & @CRLF & _
"83" & @CRLF & _
"84" & @CRLF & _
"85" & @CRLF & _
"86" & @CRLF & _
"87" & @CRLF & _
"88" & @CRLF & _
"89" & @CRLF & _
"90" & @CRLF & _
"91" & @CRLF & _
"92" & @CRLF & _
"93" & @CRLF & _
"94" & @CRLF & _
"95" & @CRLF & _
"96" & @CRLF & _
"97" & @CRLF & _
"98" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"103" & @CRLF & _
"104" & @CRLF & _
"105" & @CRLF & _
"106" & @CRLF & _
"107" & @CRLF & _
"108" & @CRLF & _
"109" & @CRLF & _
"110" & @CRLF & _
"111" & @CRLF & _
"112" & @CRLF & _
"113" & @CRLF & _
"114" & @CRLF & _
"115" & @CRLF & _
"116" & @CRLF & _
"117" & @CRLF & _
"118" & @CRLF & _
"119" & @CRLF & _
"120" & @CRLF & _
"121" & @CRLF & _
"122" & @CRLF & _
"123" & @CRLF & _
"124" & @CRLF & _
"125" & @CRLF & _
"126" & @CRLF & _
"127" & @CRLF & _
"128" & @CRLF & _
"129" & @CRLF & _
"130" & @CRLF & _
"131" & @CRLF & _
"132" & @CRLF & _
"133" & @CRLF & _
"134" & @CRLF & _
"135" & @CRLF & _
"136" & @CRLF & _
"137" & @CRLF & _
"138" & @CRLF & _
"139" & @CRLF & _
"140" & @CRLF & _
"141" & @CRLF & _
"142" & @CRLF & _
"143" & @CRLF & _
"144" & @CRLF & _
"145" & @CRLF & _
"146" & @CRLF & _
"147" & @CRLF & _
"148" & @CRLF & _
"149" & @CRLF & _
"150" & @CRLF & _
"151" & @CRLF & _
"152" & @CRLF & _
"153" & @CRLF & _
"154" & @CRLF & _
"155" & @CRLF & _
"156" & @CRLF & _
"157" & @CRLF & _
"158" & @CRLF & _
"159" & @CRLF & _
"160" & @CRLF & _
"161" & @CRLF & _
"162" & @CRLF & _
"163" & @CRLF & _
"164" & @CRLF & _
"165" & @CRLF & _
"166" & @CRLF & _
"167" & @CRLF & _
"168" & @CRLF & _
"169" & @CRLF & _
"170" & @CRLF & _
"171" & @CRLF & _
"172" & @CRLF & _
"173" & @CRLF & _
"174" & @CRLF & _
"175" & @CRLF & _
"176" & @CRLF & _
"177" & @CRLF & _
"178" & @CRLF & _
"179" & @CRLF & _
"180" & @CRLF & _
"181" & @CRLF & _
"182" & @CRLF & _
"183" & @CRLF & _
"184" & @CRLF & _
"185" & @CRLF & _
"186" & @CRLF & _
"187" & @CRLF & _
"188" & @CRLF & _
"189" & @CRLF & _
"190" & @CRLF & _
"191" & @CRLF & _
"192" & @CRLF & _
"193" & @CRLF & _
"194" & @CRLF & _
"195" & @CRLF & _
"196" & @CRLF & _
"197" & @CRLF & _
"198" & @CRLF & _
"199" & @CRLF & _
"200" & @CRLF & _
"201" & @CRLF & _
"202" & @CRLF & _
"203" & @CRLF & _
"204" & @CRLF & _
"205" & @CRLF & _
"206" & @CRLF & _
"207" & @CRLF & _
"208" & @CRLF & _
"209" & @CRLF & _
"210" & @CRLF & _
"211" & @CRLF & _
"212" & @CRLF & _
"213" & @CRLF & _
"214" & @CRLF & _
"215" & @CRLF & _
"216" & @CRLF & _
"217" & @CRLF & _
"218" & @CRLF & _
"219" & @CRLF & _
"220" & @CRLF & _
"221" & @CRLF & _
"222" & @CRLF & _
"223" & @CRLF & _
"224" & @CRLF & _
"225" & @CRLF & _
"226" & @CRLF & _
"227" & @CRLF & _
"228" & @CRLF & _
"229" & @CRLF & _
"230" & @CRLF & _
"231" & @CRLF & _
"232" & @CRLF & _
"233" & @CRLF & _
"234" & @CRLF & _
"235" & @CRLF & _
"236" & @CRLF & _
"237" & @CRLF & _
"238" & @CRLF & _
"239" & @CRLF & _
"240" & @CRLF & _
"241" & @CRLF & _
"242" & @CRLF & _
"243" & @CRLF & _
"244" & @CRLF & _
"245" & @CRLF & _
"246" & @CRLF & _
"247" & @CRLF & _
"248" & @CRLF & _
"249" & @CRLF & _
"250" & @CRLF & _
"251" & @CRLF & _
"252" & @CRLF & _
"253" & @CRLF & _
"254" & @CRLF & _
"255" & @CRLF & _
"256" & @CRLF & _
"299" & @CRLF & _
"300" & @CRLF & _
"1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")