$re = '/\bThe title\b(?= says it all)/';
$str = 'The title says it all';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);