$re = '/\b(?:the )?title\b(?= says it all)/i';
$str = 'The title says it all';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);