re = /\b(?:the )?title\b(?= says it all)/i
str = 'The title says it all. Please suggest.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end