re = /(\[.+\])/mi
str = '[\'test\', \'testse\'] , [\'test\', \'testse\']
[\'test\', \'testse\', \'estset\', [\'test\', \'testse\']]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end