re = /<span.*?>(.*)<\/span>/
str = '<span class=comment>First block with <span class=nest>nested</span> text.</span>
<stuff>
<more-badly-formatted-tags>
<td - out of nowhere>
<span class=comment>Other block with <span class=nest>nested</span> text.</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end