package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)MessageID\s*\:(\d+)\n`)
var str = `MessageID :1079247881
InstrumentID :DS5431460001
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}