re = /\b(?=[^a-zA-Z]*[a-zA-Z])(?=(?:[\D]*[\d]){7})\w{8}\b/
str = 'foo bar 123r1234 foo'
# Print the match result
str.match(re) do |match|
puts match.to_s
end