import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:31([-\\/.]?)(?:0[13578]|1[02]))\\1|(?:(?:29|30)([-\\/.]?)(?:0[1,3-9]|1[0-2])\\2))(?:(?:1[6-9]|[2-9]\\d)\\d{2})$|^(?:29([-\\/.]?)02\\3(?:(?:(?:1[6-9]|[2-9]\\d)(?:0[48]|[2468][048]|[13579][26]))))$|^(?:0[1-9]|1\\d|2[0-8])([-\\/.]?)(?:(?:0[1-9])|(?:1[0-2]))\\4(?:(?:1[6-9]|[2-9]\\d)\\d{2})$";
final String string = "02/04/2012\n"
+ "30-04-2017\n"
+ "12122019\n"
+ "12.01.2019\n\n"
+ "-- datas inválidas\n"
+ "29/02/2017\n"
+ "20-10/2019\n"
+ "31.04.2017\n"
+ "10/10/10\n"
+ "1/1/2019";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}