#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s+# renovate: datasource=(?<datasource>.*?) depName=(?<depName>.*?)( VersionTemplate=(?<VersionTemplate>.*?))?\s+-\s+(?<currentValue>\d+.\d+.\d+).*" & @CRLF & _
""
Local $sString = "---" & @CRLF & _
"" & @CRLF & _
"workflow:" & @CRLF & _
" rules:" & @CRLF & _
" - if: $CI_COMMIT_TAG" & @CRLF & _
" variables:" & @CRLF & _
" OCI_TAG_FORMAT: "$CI_COMMIT_TAG"" & @CRLF & _
" - when: always" & @CRLF & _
" variables:" & @CRLF & _
" OCI_TAG_FORMAT: "0.0.0-git-$CI_COMMIT_SHORT_SHA"" & @CRLF & _
"" & @CRLF & _
"variables:" & @CRLF & _
" REPO_URL: "$CI_REGISTRY_IMAGE"" & @CRLF & _
" REPO_IMAGE: $REPO_URL/$DISK_IMAGE_NAME:$OCI_TAG_FORMAT" & @CRLF & _
" REPO_IMAGE_SNAPSHOT: $REPO_URL/snapshots/$DISK_IMAGE_NAME:$OCI_TAG_FORMAT" & @CRLF & _
" IMAGE_FORMAT: raw" & @CRLF & _
" DISK_IMAGE_NAME: $OS-$OS_RELEASE-$FLAVOR-$K8S_FLAVOR" & @CRLF & _
" GITLEAKS_ARGS: '--verbose --log-opts=$CI_COMMIT_SHA'" & @CRLF & _
" DIB_SHOW_IMAGE_USAGE: 1" & @CRLF & _
" DIB_DEBUG_TRACE: 1" & @CRLF & _
" KANOD_OPTIONS_BASE: "-b no_kanod_network -b lvm -b growpart"" & @CRLF & _
" # renovate: datasource=docker" & @CRLF & _
" UBUNTU_CI_IMAGE: registry.gitlab.com/sylva-projects/sylva-elements/container-images/ci-disk-image-builder/ubuntu:v2.0.8" & @CRLF & _
" # renovate: datasource=docker" & @CRLF & _
" SUSE_CI_IMAGE: registry.gitlab.com/sylva-projects/sylva-elements/container-images/ci-disk-image-builder/suse:v2.0.8" & @CRLF & _
" # renovate: datasource=docker" & @CRLF & _
" GENERATE_OS_SBOM_CI_IMAGE: registry.gitlab.com/sylva-projects/sylva-elements/container-images/trivy-libguestfs:1.0.0" & @CRLF & _
"" & @CRLF & _
"stages:" & @CRLF & _
" - test" & @CRLF & _
" - build" & @CRLF & _
" - release" & @CRLF & _
" - gitleaks" & @CRLF & _
"" & @CRLF & _
"include:" & @CRLF & _
" - project: 'renovate-bot/renovate-runner'" & @CRLF & _
" ref: v18.64.1" & @CRLF & _
" file: '/templates/renovate-config-validator.gitlab-ci.yml'" & @CRLF & _
" rules:" & @CRLF & _
" - if: $CI_PIPELINE_SOURCE == 'merge_request_event'" & @CRLF & _
" changes:" & @CRLF & _
" paths:" & @CRLF & _
" - .gitlab-ci.yml" & @CRLF & _
" - renovate.json" & @CRLF & _
" - project: 'sylva-projects/sylva-elements/renovate'" & @CRLF & _
" ref: 1.0.0" & @CRLF & _
" file: '/templates/renovate-dry-run.gitlab-ci.yml'" & @CRLF & _
" rules:" & @CRLF & _
" - if: $CI_PIPELINE_SOURCE == 'merge_request_event'" & @CRLF & _
" changes:" & @CRLF & _
" paths:" & @CRLF & _
" - renovate.json" & @CRLF & _
" - project: "to-be-continuous/gitleaks"" & @CRLF & _
" ref: 2.5.2" & @CRLF & _
" file: "templates/gitlab-ci-gitleaks.yml"" & @CRLF & _
" - project: 'sylva-projects/sylva-elements/ci-tooling/ci-templates'" & @CRLF & _
" ref: 1.0.22" & @CRLF & _
" file:" & @CRLF & _
" - 'templates/release-notes.yml'" & @CRLF & _
"" & @CRLF & _
"# Override the release notes suffix to add the images produced during the build" & @CRLF & _
".release-notes-after-script:" & @CRLF & _
" - |" & @CRLF & _
" apk add curl bash jq" & @CRLF & _
" curl -sS --header "PRIVATE-TOKEN: $RELEASE_NOTES_READ_API_TOKEN" "${CI_API_V4_URL}/projects/${CI_PROJECT_ID}/pipelines/${CI_PIPELINE_ID}/bridges" \" & @CRLF & _
" | jq ".[].downstream_pipeline.id" \" & @CRLF & _
" | grep -v null \" & @CRLF & _
" | xargs -i curl -sS --header "PRIVATE-TOKEN: $RELEASE_NOTES_READ_API_TOKEN" "${CI_API_V4_URL}/projects/${CI_PROJECT_ID}/pipelines/{}/jobs" \" & @CRLF & _
" | jq '.[] | select(.name == "promote") | .id' \" & @CRLF & _
" | xargs -i curl --location --header "PRIVATE-TOKEN: $RELEASE_NOTES_READ_API_TOKEN" --output artifacts-{}.zip "${CI_API_V4_URL}/projects/${CI_PROJECT_ID}/jobs/{}/artifacts"" & @CRLF & _
" ls" & @CRLF & _
" for z in *.zip; do unzip -o $z; done" & @CRLF & _
" echo "## Produced images:" >> release-notes.md" & @CRLF & _
" echo " " >> release-notes.md" & @CRLF & _
" cat *release.md | tee -a release-notes.md" & @CRLF & _
"" & @CRLF & _
"# Override the stage to run the release notes creation after the build of the images" & @CRLF & _
"prepare-release-notes:" & @CRLF & _
" stage: release" & @CRLF & _
"" & @CRLF & _
"# Override the stage to run the release notes creation after the build of the images" & @CRLF & _
"create-release-notes:" & @CRLF & _
" stage: release" & @CRLF & _
"" & @CRLF & _
"gitleaks:" & @CRLF & _
" rules:" & @CRLF & _
" - when: never" & @CRLF & _
"" & @CRLF & _
"# Customize gitleak job imported from to-be-continuous in order to checkout main" & @CRLF & _
"# (needed for git to be able to retrieve commits from this branch not in main)" & @CRLF & _
"gitleaks-custom:" & @CRLF & _
" stage: gitleaks" & @CRLF & _
" extends: gitleaks" & @CRLF & _
" needs: []" & @CRLF & _
" before_script:" & @CRLF & _
" - echo GITLEAKS_ARGS=$GITLEAKS_ARGS" & @CRLF & _
" - !reference [gitleaks, before_script]" & @CRLF & _
" variables:" & @CRLF & _
" GITLEAKS_ARGS: '--verbose --log-opts=origin/main..HEAD'" & @CRLF & _
" rules:" & @CRLF & _
" - if: '$CI_PIPELINE_SOURCE == "pipeline"' # Do not trigger gitleaks for cross-repo pipelines" & @CRLF & _
" when: never" & @CRLF & _
" - if: $CI_BRANCH_NAME == "main"" & @CRLF & _
" variables:" & @CRLF & _
" GITLEAKS_ARGS: '--verbose' # on main, detect leaks on whole repo" & @CRLF & _
" - when: always" & @CRLF & _
"" & @CRLF & _
".kubeadm_settings:" & @CRLF & _
" variables:" & @CRLF & _
" K8S_FLAVOR: kubeadm" & @CRLF & _
" KANOD_OPTIONS_K8S: "-b kubeadm"" & @CRLF & _
" parallel:" & @CRLF & _
" matrix:" & @CRLF & _
" - K8S_VERSION:" & @CRLF & _
" # renovate: datasource=github-releases depName=kubernetes/kubernetes VersionTemplate=v" & @CRLF & _
" - 1.29.9" & @CRLF & _
" # renovate: datasource=github-releases depName=kubernetes/kubernetes VersionTemplate=v" & @CRLF & _
" - 1.28.14" & @CRLF & _
" # renovate: datasource=github-releases depName=kubernetes/kubernetes VersionTemplate=v" & @CRLF & _
" - 1.27.16" & @CRLF & _
"" & @CRLF & _
".rke2_settings:" & @CRLF & _
" variables:" & @CRLF & _
" K8S_FLAVOR: rke2" & @CRLF & _
" KANOD_OPTIONS_K8S: "-b rke2_airgapped"" & @CRLF & _
" parallel:" & @CRLF & _
" matrix:" & @CRLF & _
" - K8S_VERSION:" & @CRLF & _
" # renovate: datasource=github-releases depName=rancher/rke2 VersionTemplate=v" & @CRLF & _
" - 1.29.9-rke2r1" & @CRLF & _
" # renovate: datasource=github-releases depName=rancher/rke2 VersionTemplate=v" & @CRLF & _
" - 1.28.14-rke2r1" & @CRLF & _
" # renovate: datasource=github-releases depName=rancher/rke2 VersionTemplate=v" & @CRLF & _
" - 1.27.16-rke2r2" & @CRLF & _
"" & @CRLF & _
".ubuntu_settings:" & @CRLF & _
" variables:" & @CRLF & _
" OS: ubuntu" & @CRLF & _
" OS_RELEASE: jammy" & @CRLF & _
"" & @CRLF & _
".opensuse_settings:" & @CRLF & _
" variables:" & @CRLF & _
" OS: opensuse" & @CRLF & _
" OS_RELEASE: "15.5"" & @CRLF & _
"" & @CRLF & _
".default-trigger:" & @CRLF & _
" trigger:" & @CRLF & _
" include: .gitlab/ci/pipeline-build-and-test.yml" & @CRLF & _
" strategy: depend" & @CRLF & _
" forward:" & @CRLF & _
" pipeline_variables: true" & @CRLF & _
" rules:" & @CRLF & _
" - if: $CI_COMMIT_TAG" & @CRLF & _
" - if: $CI_PIPELINE_SOURCE == 'merge_request_event' && $CI_MERGE_REQUEST_LABELS =~ /AutoMerge/" & @CRLF & _
" - if: $CI_PIPELINE_SOURCE == 'merge_request_event'" & @CRLF & _
" when: manual" & @CRLF & _
" - if: $CI_PIPELINE_SOURCE == 'pipeline'" & @CRLF & _
" when: manual" & @CRLF & _
"" & @CRLF & _
"build-ubuntu-hardened-rke2:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .rke2_settings" & @CRLF & _
" - .ubuntu_settings" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: hardened" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S -b cis_remediation"" & @CRLF & _
"" & @CRLF & _
"build-ubuntu-plain-rke2:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .rke2_settings" & @CRLF & _
" - .ubuntu_settings" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: plain" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S"" & @CRLF & _
"" & @CRLF & _
"build-ubuntu-plain-kubeadm:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .kubeadm_settings" & @CRLF & _
" - .ubuntu_settings" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: plain" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S"" & @CRLF & _
"" & @CRLF & _
"build-opensuse-plain-rke2:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .rke2_settings" & @CRLF & _
" - .opensuse_settings" & @CRLF & _
" trigger:" & @CRLF & _
" include: .gitlab/ci/pipeline-build-and-test-suse.yml" & @CRLF & _
" strategy: depend" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: plain" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S"" & @CRLF & _
"" & @CRLF & _
"build-opensuse-plain-kubeadm:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .kubeadm_settings" & @CRLF & _
" - .opensuse_settings" & @CRLF & _
" trigger:" & @CRLF & _
" include: .gitlab/ci/pipeline-build-and-test-suse.yml" & @CRLF & _
" strategy: depend" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: plain" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S"" & @CRLF & _
"" & @CRLF & _
"build-opensuse-hardened-rke2:" & @CRLF & _
" extends:" & @CRLF & _
" - .default-trigger" & @CRLF & _
" - .rke2_settings" & @CRLF & _
" - .opensuse_settings" & @CRLF & _
" trigger:" & @CRLF & _
" include: .gitlab/ci/pipeline-build-and-test-suse.yml" & @CRLF & _
" strategy: depend" & @CRLF & _
" variables:" & @CRLF & _
" FLAVOR: hardened" & @CRLF & _
" KANOD_OPTIONS: "$KANOD_OPTIONS_BASE $KANOD_OPTIONS_K8S -b cis_remediation_opensuse"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")