$re = '/^((?:[^|]+\|){3})(?P<error>[^|]+)/m';
$str = 'as|qwe|23344|as||sada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);