re = /^(?:(?!custom|onetomany|manytomany|atom|tomcat|tomorrow|automatic).(?!custom|onetomany|manytomany|atom|tomcat|tomorrow|automatic))*?(tom).*/m
str = 'foo bar test
another tom test
but wait, automatic
but wait, tomorrow
but wait, atom tom
automatic fail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end