$re = '~(?:(?P<value>\d+(?:\.\d+)*?)\h)?(?P<unit>ACT\sFC)~';
$str = '1.0 ACT FC';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);