package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\w+`)
var str = `#cookie #recipe #chocolate To do this you have to etc...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}