import re
regex = re.compile(r"(background:\s*url\((https?:\/\/)*([a-zA-Z0-9._:\/\s*]*)\)\s*[a-zA-Z0-9\s*-._:\/;]*)")
test_str = (".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;\n"
"}\n\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(https://instant/templates/_default_/images/nyromodal/close.gif);\n"
"}\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(../instant/templates/_default_/images/nyromodal/close.gif);\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")