$re = '/^(?!.*?foo).*bar.*/m';
$str = '"this is foo baz bar" - should not match
"this is foo baz" - should not match
"this is baz bar" - should match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);