re = /(?<!\\)(?:\\\\)*".*?(?<!\\)(?:\\\\)*"/
str = '" a daf asd \\\\"
\\\\" adf "
\\\\" foo "
\\\\" foo bar baz \\\\" foo bar \\"
\\\\\\" foo bar \\\\\\"
\\\\\\\\" foo \\\\\\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end