re = /^(?:[^-]+-){3}(?:4[5-9]|[35][0-9])[0-9](?:-[^-]+){4}\.pdf$/m
str = 'a-b-c-459-s-d-f-s.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end