$re = '/^#([A-Za-z0-9]+)(?!\S)/m';
$str = '#type1 this is the text of the note
#type1test this is the text of the note
#type this is the text of the note
#type1.testthis is the text of the note
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);