$re = '/^(?!\d*$)[a-z0-9]{8,20}$/m';
$str = '33333333333
33333333333a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);