$re = '/<a[^>]*>[^<]*<\/a>
=/';
$str = '<a href="http://www.mylink.com">whatever</a>
<a rel="text" href="http://www.mylink.com">whatever</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);