const regex = new RegExp('(\\d\\d{0,1}){1}(:\\d\\d{0,1}){0,1}(\\sa.m|\\sp.m){0,1}', '')
const str = `set alarm at 33:20 p.m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}