$re = '/#©Yuri Khmelenko
#Ограничитель 1
((\<)|(\()|(\[)|(\{)|
((?=[[:ascii:]])[^\s\w\\\\\)\]\}\>]))
#Шаблон
((?#ignore comments like this in the regular expression)
(?(6)
(?(?=(?:(?!\6).|(?<=\\\\)\6)*[^\\\\][\(][\?][\#])
(?:(?!\6).|(?<=\\\\)\6)*[^\\\\][\(][\?][\#]
[^\)]*(?-1)))
.*?)
#Ограничитель 2
#экранизированные обратные слеши +
#неэкранизированный ограничитель
(?(2)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\>)
(?(3)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\))
(?(4)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\])
(?(5)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\})
(?(6)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\6)
#Модификаторы шаблонов
#PHP [mixXsuUAJ] JavaScript [gmi] python [gmixsu]
((?(6)(?:[mixXsuUAJ]*)|(?(?=.*?[mixXsuUAJ]+)[mixXsuUAJ]+)))/xs';
$str = '
/ав(?#\\ / )ава/imsuUJA (fl(d)k(?#fj)ldkf)j)isus <dlkfjdlfkj>ixu [dfdfd]im
((()()()()()())(((()))i
/s/ %lfkjfl%isuAJ .dfjldkfj. ,dlkjdlfk\\\\\\, , jhlkjlkj /ldkjfl(?#/)dfkjldkj/
{dsaff}i
/#Ограничитель http:
(?>(\\<)|(\\()|(\\[)|(\\{)|
((?=[[:ascii:]])[^\\s\\w\\\\]))
#шаблон:
(.*?)
#Ограничитель 2
(?(1)\\>) (?(2)\\)) (?(3)\\]) (?(4)\\})
(?(5)(?:
#до не экранированного ограничителя
#экранирование которого не экранированно
(?:(?<=\\\\\\\\)\\5)|
(?:(?<!\\\\)\\5)
))
#Модификаторы шаблонов
([mixXsuUAJ]*)/im
/#©Yuri Khmelenko
#Ограничитель 1
(?>(\\<)|(\\()|(\\[)|(\\{)|
((?=[[:ascii:]])[^\\s\\w\\\\]))
#Шаблон + Ограничитель 2
(?(1)(.*?)(?<!\\\\)\\>)
(?(2)(.*?)(?<!\\\\)\\))
(?(3)(.*?)(?<!\\\\)\\])
(?(4)(.*?)(?<!\\\\)\\})
(?(5)(.*?)(?<!(?<!(?<!(?<!(?<!(?<!(?<!(?<!\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\\\)\\5)
#Модификаторы шаблонов
([mixXsuUAJ]*)/xus';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);