import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<date>\\d{4}\\-\\d{2}\\-\\d{2}\\s+)(?<time>\\d{2}\\:\\d{2}\\:\\d{2}\\s+)(?<sip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\s+)(?<csmethod>.+?\\s+)(?<csuristem>.+?\\s+)(?<csuriquery>.+?\\s+)(?<sport>\\d{1,3}\\s+)(.+?\\s+)(?<cip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\s+)(?<csUseragent>.+?\\s+)(?<scstatus>\\d{1,3}\\s+)(?<scsubstatus>\\d{1,3}\\s+)(?<scwin32status>\\d+\\s+)(?<scbytes>\\d+\\s+)(?<csbytes>\\d+\\s+)(?<timetaken>\\d+)?$";
final String string = "2014-05-06 10:27:17 10.200.40.56 GET / - 443 - 10.200.28.7 Mozilla/5.0+(compatible;+MSIE+9.0;+Windows+NT+6.1;+WOW64;+Trident/5.0) 401 2 2148074254 1880 428 109";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}