package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(file\..*?)"?$`)
var str = `cd ..\folder\file.xml"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}